Skip to content

This website works best using cookies which are currently disabled.Cookie policy  Allow cookies
Equatorial Guinea Change
 
Messages

No risk from Heartbleed vulnerability

JobServe can confirm that it has been unaffected by the recent internet software vulnerability, named Heartbleed within the media. JobServe has never used the affected software so there is no direct risk for our users. More info

22 hours ago